PHP 7 compatibility

Tagged: 

This topic contains 0 replies, has 1 voice, and was last updated by  visnjamvf 1 year, 1 month ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #1854

    visnjamvf
    Participant

    Hi,

    Can you please make this plugin PHP 7 compatible?

    Here are the errors and warnings:

    FILE: /wp-content/plugins/itro-wordpress-marketing/file_4.php
    ——————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————–
    1 | WARNING | File has mixed line endings; this may cause incorrect results
    ——————————————————————————————–

    FILE: /wp-content/plugins/itro-wordpress-marketing/folder_1/file_3.php
    ————————————————————————————————————————-
    FOUND 1 ERROR AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————————-
    8 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    8 | ERROR | Using ‘break’ outside of a loop or switch structure is invalid and will throw a fatal error since PHP 7.0
    ————————————————————————————————————————-

    FILE: /wp-content/plugins/itro-wordpress-marketing/folder_6/MCAPI.class.php
    ————————————————————————————————————–
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    ————————————————————————————————————–
    39 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    2900 | WARNING | INI directive ‘magic_quotes_runtime’ is deprecated since PHP 5.3 and removed since PHP 5.4.

    We want to migrate all of our sites to the server with PHP 7 but unable to do so as a few plugins are not PHP 7 compatible. SO we’re contacting each plugin author.

    Do you know when you’ll be releasing PHP 7 compatible version?

    Many thanks.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.